程序化指标公式
问答中心

程序化指标-多空买卖加仓主图公式

程序化指标公众号 2020-11-26阅读量:2797

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

AS:=(C*3+O+H+L)/6;
XJ:=(AS+0.618*REF(AS,1)+0.382*REF(AS,2)+0.236*REF(AS,3)+0.146*REF(AS,4))/2.382;
HLX:=EMA(HHV(XJ,3),15);
LLX:=EMA(LLV(XJ,3),15);
CH:=CROSS(XJ,HLX);
CL:=CROSS(LLX,XJ);
CHH:=BARSLAST(CH);
CLL:=BARSLAST(CL);
YF1:=(CHH<CLL OR CH) AND NOT(CL);
TF:=IF(YF1,LLX,HLX);
TFB:=(HLX+LLX)/2;
XJK:=SMA(EMA(XJ,3),3,1);
ZWSH:=(HHV(XJ,2)+HHV(XJ,3)+HHV(XJ,4)+HHV(XJ,5))/4;
SH:=EMA(ZWSH,21);
ZWSL:=(LLV(XJ,2)+LLV(XJ,3)+LLV(XJ,4)+LLV(XJ,5))/4;
SL:=EMA(ZWSL,21);
SCH:=CROSS(XJ,SH);
SCL:=CROSS(SL,XJ);
SHH:=BARSLAST(SCH);
SLL:=BARSLAST(SCL);
SF1:=(SHH<SLL OR SCH) AND NOT(SCL);
TFS:=IF(SF1,SL,SH);
MX:=EMA(C,2);
MXA:=EMA(SLOPE(C,21)*20+C,42); 
CP:=MA(CLOSE,9),COLORCYAN,LINETHICK1;
JD:=MA(CLOSE,18),COLORMAGENTA;
HH:=HHV(HIGH,10);
LL:=LLV(LOW,10);
HH1:=BARSLAST((HH > REF(HH,1)));
LL1:=BARSLAST((LL < REF(LL,1)));
DRAWTEXT_FIX(1,0.62,0,0,'☆微信公众号:(程序化指标) ☆'),COLORRED;
IF((HH1 < LL1),LL,DRAWNULL),LINETHICK3,COLORRED;
IF((HH1 > LL1),HH,DRAWNULL),LINETHICK2,COLOR00FF00;
STICKLINE((HH1 < LL1),CLOSE,OPEN,3,0),COLORRED;
STICKLINE((HH1 < LL1),HIGH,LOW,0,0),COLORRED;
STICKLINE((HH1 > LL1),CLOSE,OPEN,3,0),COLORFF0000;
STICKLINE((HH1 > LL1),HIGH,LOW,0,0),COLORFF0000;
DRAWICON(CROSS(HH1,LL1),HH,43);
DRAWICON(CROSS(LL1,HH1),LL,42);
DRAWTEXT(CROSS(HH1,LL1),HH,'卖'),COLORWHITE;
DRAWTEXT(CROSS(LL1,HH1),LL,'买'),COLORFF00FF;
DRAWICON(CROSS(CP,JD) AND MX>=MXA,L,1);
DRAWTEXT(CROSS(CP,JD) AND MX>=MXA,L,'↖加仓'),COLORYELLOW;
DRAWBAND(TFB,RGB(150,00,40),TFS,RGB(00,00,80));
DRAWBAND(TFB,RGB(250,00,00),TF,RGB(00,150,00));

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭