程序化指标公式
问答中心

通达信阶段操盘提醒主图指标公式

通达信指标 2019-05-29阅读量:775

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击  安装指南  步骤操作


范围高A:=REFDATE(HHV(H,120),DATE)*1.05;
范围低A:=REFDATE(LLV(L,120),DATE)*0.95;
MA5:=MA(C,5),COLORCYAN,LINETHICK2;
MA24:=MA(C,24),COLORGREEN,LINETHICK2;
MA72:=MA(C,72),COLORRED,LINETHICK2;
MA200:=IF((MA(C,200)<=范围高A AND MA(C,200)>=范围低A) OR C>=MA(C,200),MA(C,200),DRAWNULL),COLORBLUE,LINETHICK2;
DRAWTEXT_FIX(C>O,0.01,0.9,0,' 微信公众号:程序化指标    网址:WWW.HONGHAIE.COM '),COLORRED;
引差:=REF(C,1)-LOW,LINETHICK1,NODRAW;
引跌幅:IF((REF(C,1)-LOW)/REF(C,1)*100>0,(REF(C,1)-LOW)/REF(C,1)*100,0),LINETHICK1,NODRAW;
三日均跌:MA(引跌幅,3),COLORWHITE,NODRAW;
N:=120;
K:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0)),NODRAW;{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0)),NODRAW;{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);
高区:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2,NODRAW;
低区:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2,NODRAW;
平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;
支撑:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;
强势: IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;
警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
压力:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.809,DRAWNULL),COLOR00FF00;
低涨:IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
顶点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT,NODRAW;
低点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT,NODRAW;
STICKLINE(CCI>=200 AND H>=顶点,O,C,2,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;
DRAWBAND(高区,RGB(0,0,0),平衡,RGB(0,0,0));
DRAWBAND(平衡,RGB(0,0,0),低区,RGB(0,0,0));
DRAWBAND(高,RGB(120,100,0),压力,RGB(0,0,0));
DRAWBAND(压力,RGB(258,58,0),警示,RGB(0,0,0));
DRAWBAND(警示,RGB(128,58,0),突破,RGB(0,0,0));
DRAWBAND(突破,RGB(68,0,0),强势,RGB(0,0,0));
DRAWBAND(强势,RGB(38,0,0),支撑,RGB(0,0,0));
DRAWBAND(支撑,RGB(38,38,38),低,RGB(0,0,0));
STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080,NODRAW;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,'【风险区】--高抛避险'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,'【警示区】--逢高减仓'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.45,'【突破区】--主力拉升'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,'【拉升区】--强势畜锐'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/3,'【关注区】--逢低买入'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,'【低吸区】--大胆买入'),COLORFFFFFF;
第一防线:REFDATE(低,DATE),DOTLINE,COLORYELLOW,NODRAW;
第二防线:REFDATE(支撑,DATE),DOTLINE,COLORWHITE,NODRAW;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299;
DRAWKLINE(H,O,L,C);
AHC1:=CLOSE*VOL;{程序化指标 WWW.HONGHAIE.COM}
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上轨:=1.06*AHC22,COLOR40FF00,LINETHICK1;
下轨:=AHC22*0.94;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;
DRAWTEXT(启爆,L,'启爆'),COLORCYAN;
STICKLINE(启爆,C,O,3,1),COLORWHITE;
STICKLINE(启爆,C,O,1,0),COLORGREEN;
STICKLINE(C>=O ,HIGH,LOW,0,1 ),COLORRED; 
STICKLINE(C>=O ,OPEN,CLOSE,3.1,0 ),COLOR000033;
STICKLINE(C>=O,OPEN,CLOSE,2.7,0 ),COLOR000066; 
STICKLINE(C>=O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(C>=O ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(C>=O ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(C>=O ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;
STICKLINE(C<O ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000; 
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE<O ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
CC:IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLOR000000,NODRAW;
止赢:1.05*CC,COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,止赢,'止赢'),LINETHICK2;
止损:0.97*CC,COLORYELLOW,LINETHICK2;
DRAWTEXT(ISLASTBAR,止损,'止损'),LINETHICK2;
DRAWNUMBER(ISLASTBAR  ,C,C),COLORWHITE;
AAA:=CONST(HHV(H,50));PL5:=HHV(H,45); 
F:=100*(C-REF(C,1))/REF(C,1);
博尔:=IF(C<REF(O,1) AND F<0,1,0);
P1:=博尔;
量化:=IF(C<REF(O,2) AND F<0,1,0);
P2:=量化;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLOR0055FF;
操作30日均线:EMA(C,30),COLORYELLOW,LINETHICK4;
红升:IF(操作30日均线>REF(操作30日均线,1),操作30日均线,DRAWNULL),COLORRED,LINETHICK4;
绿降:IF(操作30日均线<REF(操作30日均线,1),操作30日均线,DRAWNULL),COLOR009300,LINETHICK4;
趋势55日线:EMA(C,55),COLORYELLOW,LINETHICK1,NODRAW;
红升4:IF(趋势55日线>REF(趋势55日线,1),趋势55日线,DRAWNULL),COLOR0080FF,LINETHICK1;
绿降4:IF(趋势55日线<REF(趋势55日线,1),趋势55日线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;
年线:EMA(C,250),COLORYELLOW,LINETHICK1,NODRAW;
年红升:IF(年线>REF(年线,1),年线,DRAWNULL),COLOR8000FF,LINETHICK1;
年绿降:IF(年线<REF(年线,1),年线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告二

左边广告一

关闭

右边广告二

关闭