程序化指标公式
问答中心

程序化指标-财神来敲门指标公式

程序化指标公众号 2021-02-16阅读量:987

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

MMM:=1;
ZK1:="KD.K#WEEK"(9,3,3);
ZD2:="KD.D#WEEK"(9,3,3);
换手:=V/CAPITAL*100,LINETHICK0;
JCD:=CROSS(ZK1,ZD2) AND REF(ZD2,1)<60;
波段低点:=EXIST(JCD,MMM),COLORYELLOW,NODRAW;
VAR1A:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR4AA:=CLOSE/(REF(CLOSE,1))>1.05 AND (HIGH/CLOSE<1.01);{1.05;1.01}
游资进场:=(FILTER(VAR4AA>0,34)AND DYNAINFO(4)>0)*8,COLORYELLOW;{34;4;8}
STICKLINE(游资进场,10,18,2.4,0),COLORWHITE;{白色柱}
DRAWTEXT(游资进场,18,' 要拉一波'),COLORMAGENTA;

{财神来敲门}

LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,6),2.1*FORCAST(V,6));
拉升:=FILTER(LS,10);
STICKLINE(拉升,0,16,1,0),COLORBROWN;
DRAWICON(拉升,16.2,9);
A1J:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,10))/EMA(CLOSE,10)); {23}
A2J:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1J); 
金线王:=EMA(A2J,5)*1;{200}
金线王2:=EMA(A2J,200)*1.118;{200}
条件:=(C-REF(C,1))/REF(C,1)*100>8;
金K线:=CROSS(C,金线王) AND 条件;
RRFJ:=金K线,STICK;
STICKLINE(IF(RRFJ,20,0),+10,0,2,0),COLORYELLOW;
VAR11:=REF(LOW,1);
VAR2H:=(SMA(ABS(LOW-VAR11),13,1))/(SMA(MAX(LOW-VAR11,0),13,1))*4;

VAR3H:=EMA(VAR2H,13);

VAR4H:=LLV(LOW,34);

VAR5H:=EMA(IF(LOW<=VAR4H,VAR3H,0),3);

VAR6H:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)

+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR7H:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)

+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR8H:=VAR6H<REF(VAR7H,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

STICKLINE(VAR8H AND COUNT(VAR8H,18)=1,0,6,4,0),COLORBROWN;{粉色住}
T1R:=MA(MA(MA(EMA(CLOSE,1),2),2),2);

TR1:=EMA((T1R-REF(T1R,1))/REF(T1R,1),1)*1000,COLORFF00FF,NODRAW;

净:=MA(TR1,11);

流:=EMA(净,11);

主力动向:=EMA(净+流,1)-MA(净-流,2),COLORFF00FF,NODRAW;

MA1:=MA(主力动向,13),COLORFF00FF,NODRAW;

MA3:=EMA(MA1,2);

LC:=REF(CLOSE,1);

RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

VWR5:=C>MAX(REF(C,1),REF(O,1)) AND C/MAX(REF(C,1),REF(O,1))>1.02;

VWR6:=REF(VWR5,1) AND VWR5=0;

DOWNQK1:=RSI>76;

VWR8:=VWR6 AND DOWNQK1;

VWR9:FILTER(VWR8,10);

{MACD低位金叉附图;这个MACD不同于以往的MACD,它的柱状体会随着上攻动能增加变红色。

会随着上攻动能对敲出货,而柱状缩小变色,与正在拉升的K线动能呈反向走势,让买卖点更清晰。}

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV6:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV7:=EMA(OBV6,3)-MA(OBV6,9);

OBV8:=EMA(IF(OBV7>0,OBV7,0),3);

MAC:=MA(C,3);

RC:=DYNAINFO(3);

AP:=VOL*C; 

BP:=SUM(AP,1)/SUM(VOL,1);

B1:=EMA(BP,17); 

资金:=(BP-B1)*100/BP; 

DIF:=EMA(资金,12)-EMA(资金,26),COLORGREEN;

DEA:=EMA(DIF,9),COLORCYAN;

MACD:=(DIF-DEA)*2,;

STICKLINE(OBV8>REF(OBV8,1) AND MAC>REF(MAC,1),0,MACD,3,0),COLORRED;

{持币:STICKLINE((SAR(10,2,20)>=H),MACD,0,1.5,0),COLORGREEN;

持股:STICKLINE((SAR(10,2,20)<=L),0,MACD,1.5,0),COLORCYAN;}

吸:=XLPL.NOTEXT吸,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

拉:=XLPL.NOTEXT拉,COLORRED,CIRCLEDOT,LINETHICK3;

派:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;

落:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;

STICKLINE(吸,0,MACD,4,0),COLORYELLOW;

STICKLINE(拉,0,MACD,4,0),COLORMAGENTA;

{STICKLINE(派,0,MACD,10,1),COLORGRAY;

STICKLINE(落,0,MACD,10,1),COLORGRAY;};

{零轴下红色资金活跃块。属于左侧信号,用于研判右侧交易是否确立信号}

DIFZ:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEAZ:=EMA(DIFZ,9);

MACD6:=(DIFZ-DEAZ)*2,COLORSTICK;

主力进驻:=COUNT(MACD6<0,10)=10,COLORRED,NODRAW;

{STICKLINE(主力进驻,0,MACD6*1,10,0),COLORRED;}

{MACD低位金叉附图;这个MACD不同于以往的MACD,它的柱状体会随着上攻动能增加变色。

会随着上攻动能对敲出货,而柱状缩小变色,与正在拉升的K线动能呈反向走势,让买卖点更清晰。}

VA1:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA1),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

RCC:=DYNAINFO(3);

AP3:=VOL*C; 

BP3:=SUM(AP3,1)/SUM(VOL,1);

B13:=EMA(BP3,17); 

资金1:=(BP3-B13)*100/BP3; 

DIF3:=EMA(资金1,12)-EMA(资金1,26),COLORGREEN;

DEA3:=EMA(DIF3,9),COLORCYAN;

MACD1:=(DIF3-DEA3)*2,;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORMAGENTA;

持币1:STICKLINE((SAR(10,2,20)>=H),MACD1,0,1.5,0),COLORGREEN;

持股1:STICKLINE((SAR(10,2,20)<=L),0,MACD1,1.5,0),COLORCYAN;

吸1:=XLPL.NOTEXT吸,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

拉1:=XLPL.NOTEXT拉,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

派1:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;

落1:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;

STICKLINE(吸1,0,MACD1,2,0),COLORMAGENTA;

STICKLINE(拉1,0,MACD1,2,0),COLORMAGENTA;

STICKLINE(派1,0,MACD1,3,0),COLORGREEN;

STICKLINE(落1,0,MACD1,2,0),COLORBLUE;

{▲主图有金坑吸筹,无金坑放弃。}

LCF:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE - LCF),0),5,1) / SMA(ABS((CLOSE - LCF)),5,1)) * 100);

TR1F:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);

PDI:=((DMP * 100) / TR1F);

MDI:=((DMM * 100) / TR1F);

ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

WR10:=((100 * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60)));{10}

NEWVOL:=(RSI5 - WR10);

金坑买入:=(AV + NEWVOL);

买入选股:=IF(CROSS(金坑买入,0),1,0),STICK,COLORRED;{NODRAW}

VAR1Z:=SMA(买入选股,8,1);{3}

VAR2Z:=SMA(VAR1Z,8,1),COLOR0000FF;{3}

VAR3Z:=SMA(VAR2Z,10,1),COLOR00FFFF;{3}

金坑吸筹:=IF(CROSS(VAR2Z,VAR3Z) AND (VAR2Z<40),5,0* 10000),COLOR0000FF,LINETHICK1;{40}

STICKLINE(金坑吸筹,0,8,1,0),COLORMAGENTA;

DRAWTEXT(金坑吸筹>0,8,'▲主图有金坑吸筹'),COLORLIRED;

MACD2:=(DIF-DEA)*2,;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD2,3,0),COLORYELLOW;

持币2:STICKLINE((SAR(10,2,20)>=H),MACD2,0,1.5,0),COLORGREEN;

持股2:STICKLINE((SAR(10,2,20)<=L),0,MACD2,1.5,0),COLORCYAN;

吸2:=XLPL.NOTEXT吸,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

拉2:=XLPL.NOTEXT拉,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

派2:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;

落2:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;

STICKLINE(吸2,0,MACD2,1.2,0),COLORMAGENTA;

STICKLINE(拉2,0,MACD2,1.7,0),COLORMAGENTA;

STICKLINE(派2,0,MACD2,2,0),COLORBLUE;

STICKLINE(落2,0,MACD2,1,1),COLORGRAY;

{开始控盘黄箭头}

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*350;


A10:=CROSS(控盘,0);

无庄控盘:=IF(控盘<0,控盘,0),COLORWHITE,NODRAW;


STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;

有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;

VAR2F:=100*WINNER(CLOSE*0.95);

STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;{绿};

DRAWTEXT(游资进场,18,' 要拉一波'),COLORMAGENTA;

DRAWTEXT(拉升,16,'▲财神来敲门'),COLORYELLOW;{1.048;0.2;2.1}

DRAWTEXT(RRFJ,10.5,'▲金K迎财神'),COLORYELLOW;

DRAWTEXT(VAR8H AND COUNT(VAR8H,18)=1,6,'●金K底时买'),COLORWHITE;

DRAWTEXT(波段低点,-4,'▲黑夜之眼'),COLORWHITE;

{成交放量}

AA:=VOL;

BB:=REF(MA(VOL,5),1);{5}

CC:=AA/BB;

A1:=CC>=0.001 AND CC<0.5;

A2:=CC>=0.5 AND CC<0.8;

A3:=CC>=0.8 AND CC<1.5;

A4:=CC>=1.5 AND CC<2.3;{2.5}

A5:=CC>=2.5 AND CC<5.0;

A6:=CC>=5.0 AND CC<10.0;

A7:=CC>=10.0 AND CC<20.0;

关注线:1.5,COLORFFFFFF,LINETHICK1;

温和放量:=A4,STICK,COLOR00CCFF;

STICKLINE(A5,0,CC,2,0),COLORBLUE; 

明显放量:A5,STICK,COLORLIBLUE;

DRAWTEXT(明显放量,3.5,'▲中量'),COLORWHITE;

XG:STICKLINE(A6,0,CC,1.2,0),COLORBLUE;

DRAWTEXT(XG,7,'▲成交大量'),COLORCYAN;

放量线:2.5,COLORRED,LINETHICK2;

今日量比:VOL/REF(MA(VOL,5),1),COLORFFFFFF,NODRAW;



版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告一

右边广告二

关闭