程序化指标公式
问答中心

通达信红绿灯主图指标公式

通达信指标 2019-06-21阅读量:1508

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作

MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORBLUE;
MA30:MA(C,21),COLORRED;
{程序化指标官方网址 WWW.HONGHAIE.COM}
X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
STICKLINE(X2>=X3,LOW,HIGH,0.1,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(X2<X3,LOW,HIGH,0.1,1),COLORGREEN;
STICKLINE(X2<X3,CLOSE,OPEN,3,1),COLORGREEN;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,4,0),COLORYELLOW;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,4,0),COLORBLUE;
VAR1A:=REF(CLOSE,1);
VAR2A:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
VAR3A:=(CLOSE-VAR1A)*VAR2A;
VAR4:=SUM(VAR3A,0);
VAR5:=SMA(VAR4,5,1);
VAR6:=SMA(VAR4,8,1);
OSC:=VAR5-VAR6;
OSCMA:=MA(OSC,4);
VD:=SUM(IF(OSC>0,OSC*1.003,OSC*1.003>0),34)/34;
VE:=SUM(IF(OSC<=0,OSC*0.97,OSC*0.97<0),34)/34;
VARW:=(C/REF(C,1)-1)*100<=4;
DRAWTEXT(CROSS(OSC,VD) AND VARW,L-0.1,'加仓'),COLORRED;
KOH:=L>REF(H,1);
KOL:=H<REF(L,1);
HIF:=L>REF(H,BARSLAST(KOH)+1);
NHIF:=L<=REF(H,BARSLAST(KOH)+1);
LIF:=H<REF(L,BARSLAST(KOL)+1);
NLIF:=H>=REF(L,BARSLAST(KOL)+1);{程序化指标官方网址 WWW.HONGHAIE.COM}
DRAWICON(HIF AND BARSLAST(KOH)<BARSLAST(NHIF) AND BARSLAST(HIF)<BARSLAST(NHIF),REF(H,BARSLAST(KOH)+1),1);
DRAWICON(LIF AND BARSLAST(KOL)<BARSLAST(NLIF) AND BARSLAST(LIF)<BARSLAST(NLIF),REF(L,BARSLAST(KOL)+1),2);

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭