程序化指标公式
问答中心

通达信交易趋势提示主图指标公式

通达信指标 2019-08-17阅读量:497

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作

ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
买线:=EMA(C,1);
卖线:=EMA(SLOPE(C,30)*10+C,45);{程序化指标官方网址 WWW.HONGHAIE.COM}
STICKLINE(买线>=卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR00004F;
STICKLINE(买线<卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR372500;
STICKLINE(买线>=卖线,L,H,0,1 ),COLOR8080FF;
STICKLINE(买线>=卖线,C,O,3.1,0 ),COLOR000033;
STICKLINE(买线>=卖线,C,O,2.1,0 ),COLOR000099;
STICKLINE(买线>=卖线,C,O,1.5,0 ),COLOR0000CC;
STICKLINE(买线>=卖线,C,O,0.3,0 ),COLORCC66FF;{以上为阳实体}
STICKLINE(买线<卖线,L,H,0,0 ),COLORFFFF00;
STICKLINE(买线<卖线,C,O,3.1,0 ),COLOR000000;
STICKLINE(买线<卖线,C,O,2.1,0 ),COLOR6A6A00;
STICKLINE(买线<卖线,C,O,1.5,0 ),COLORDDDD00;
STICKLINE(买线<卖线,C,O,0.3,0),COLORFFFF00;{立体青色};
MA1:EXPMA(C,5),DOTLINE,COLORYELLOW,LINETHICK1;
KK:=MA1 IF(KK,MA1,DRAWNULL),DOTLINE,COLOR00FF00,LINETHICK1;
DD1:=MA1>REF(MA1,1);
IF(DD1,MA1,DRAWNULL),COLOR00FFFF,LINETHICK2;
操作线20日:EMA(C,20),POINTDOT,COLOR0000FF,LINETHICK1;
红升:IF(操作线20日>REF(操作线20日,1),操作线20日,DRAWNULL),COLOR0000FF,LINETHICK3;
绿降:IF(操作线20日 均价:=(3*C+H+L+O)/6;
VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+
4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;
SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;
SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;
SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND CLOSE>VAR2 AND CLOSE SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)
AND CLOSEVAR2 AND VAR1 AND VAR2 SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE XD1:=VAR1=VAR2 AND CLOSE AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE XD2:=VAR1=VAR2 AND CLOSE>VAR1;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:=IF(SAT>1,1,SAT)*100;{程序化指标官方网址 WWW.HONGHAIE.COM}
DRAWTEXT_FIX(BARSTATUS=2 AND SZ1,0.8,0.05,0,'调整结束短线介入'),COLORFFFFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ2,0.8,0.05,0,'上升通道走势良好'),COLORFFFFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ3,0.8,0.05,0,'股价偏离注意调整'),COLORFFFFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ4,0.8,0.05,0,'上升通道调整洗盘'),COLORFFFFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ5,0.8,0.05,0,'转向特征注意离场'),COLOR00FFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ6,0.8,0.05,0,'通道改变坚决离场'),COLORFFFF00;
DRAWTEXT_FIX(BARSTATUS=2 AND XD1,0.8,0.05,0,'下跌通道只宜观望'),COLORFFFF00;
DRAWTEXT_FIX(BARSTATUS=2 AND XD2,0.8,0.05,0,'短期底部准备进入'),COLORYELLOW;



版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告二

左边广告一

关闭

右边广告二

关闭