程序化指标公式
问答中心

通达信不上长城非好汉主图指标公式

通达信指标 2019-08-18阅读量:834

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作

MM1:=5;

MM2:=13;

MM3:=21;

MM4:=34;

MM5:=55;

MM6:=89;

MM7:=144;

MM8:=233;

M5:=EMA(C,MM1);

M13:=EMA(C,MM2);

M21:=EMA(C,MM3);

M34:=EMA(C,MM4);

M55:=EMA(C,MM5),POINTDOT,LINETHICK2,COLOR3366DD;

M89:=EMA(C,MM6),POINTDOT,LINETHICK2,COLOR66FFAA;

M144:=EMA(C,MM7),POINTDOT,LINETHICK2,COLOR6633FF;

M233:=EMA(C,MM8),POINTDOT,LINETHICK2,COLOR6666FF;

B1:=CONST(LLV(LOW,19));

B2:=CONST(HHV(HIGH,19));

{程序化指标官方网址 WWW.HONGHAIE.COM}

支撑价:=IF(CURRBARSCOUNT<19,B1,DRAWNULL), COLORLIRED,CIRCLEDOT;

阻力价:=IF(CURRBARSCOUNT<19,B2,DRAWNULL),COLORLIBLUE,CIRCLEDOT;

买线1:EMA(C,8);

卖线1:EMA(买线1,18);

VAR11:=(HHV(H,36)-C)/(HHV(H,36)-LLV(L,36))*100;

VAR2:=SMA(VAR11,5,1);

VAR33:=SMA(VAR2,8,1);

VAR4:=CROSS(VAR2,VAR33) AND VAR33< 20;

VAR5:=C>LLV(C,60)*1.13 AND VAR4;

VAR66:=IF(C>200,VAR4,VAR5);

STICKLINE(买线1>卖线1,买线1,卖线1,0,1),COLORRED;

STICKLINE(买线1< 卖线1,买线1,卖线1,0,1),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=120,0.4,0.01,0,'微信公众号:  程序化指标'),COLORGREEN;

IF(买线1>REF(买线1,1),买线1,DRAWNULL),COLORRED,LINETHICK2;

IF(买线1
IF(卖线1>REF(卖线1,1),卖线1,DRAWNULL),COLORRED,LINETHICK2;

IF(卖线1
STICKLINE(C>=卖线1,LOW,HIGH,0,1),COLORRED;

STICKLINE(C>=卖线1,CLOSE,OPEN,3.2,2),COLORRED;

STICKLINE(C<卖线1,LOW,HIGH,0,1),COLORGREEN;

STICKLINE(C<卖线1,CLOSE,OPEN,3.2,2),COLORGREEN;

STICKLINE(CROSS(卖线1,C),OPEN,CLOSE,3.2,0),COLORGREEN;

STICKLINE(CROSS(C,卖线1),OPEN,CLOSE,3.2,0),COLORRED;

{程序化指标官方网址 WWW.HONGHAIE.COM}

STICKLINE((CLOSE>OPEN) AND (C<卖线1),CLOSE,OPEN,3.2,2)COLORGREEN;

STICKLINE((CLOSE>OPEN) AND (C>=卖线1),CLOSE,OPEN,3.2,2)COLORRED;

STICKLINE((CLOSE
STICKLINE((CLOSE=卖线1),CLOSE,OPEN,3.2,0)COLORRED;

{旱地拔葱}

D1:=19;

D2:=BARSLAST(LLV(LOW,D1)=L);

D3:=BARSLAST(C/REF(C,1)>1.09);

D4:=D3-D2;

D5:=D4>=0 AND D4<3;

D6:=FILTER(D5,D1);

D7:=COUNT(C/REF(C,1)>1.05,12)>=9;

DRAWTEXT(D6 OR D7,L,'☆旱地拔葱'),COLORLICYAN;

D8:=COUNT(D6,3)>0;

D9:=C>M13 AND C
DRAWTEXT(D8 AND D9 ,L,'☆厚积薄发'),COLORLICYAN;

{微信公众号:程序化指标}

E1:=5; E2:=3;

E3:=C/REF(C,1)>=1 AND C/REF(C,1)<1.02;

E4:=V/REF(V,1)>1;

E5:=COUNT(E3 AND E4,E1)>=E2;

E6:=FILTER(E5,E1);

DRAWTEXT(E6,L,'☆小阳放量滞涨'),COLORLIGREEN;

{轻舟越过万重山}

F1:=V/CAPITAL*100<3;

F2:=C>M233*1.03 AND C1.04 AND REF(C,1)
F3:=F2 AND F1;

DRAWTEXT(F3,L,'☆轻舟越过万重山'),COLORLIBLUE;

{空头强驽之末}

FF1:=M55>M34 AND M34>M13;

FF2:=C
FF3:=FF1 AND FF2;

DRAWTEXT(FF3,L,'☆空头强驽之末'),COLORLIBLUE;

{黄金买点}

G1:=CONST(LLV(LOW,55));

G2:=CONST(HHV(HIGH,55));

G3:=G2-G1;

G4:=C<(G2-G3*0.382)*1.05 AND C>(G2-G3*0.382)*0.98;

G5:=FILTER(G4,10);

DRAWTEXT(G5 AND CURRBARSCOUNT<10,L,'☆黄金买点'),COLORLIBLUE;

{假阴线}

H1:=REF(C,1)/REF(C,2)>1.0985;

H2:=O>REF(H,1) AND O>C;

H3:=V/REF(V,1)>1.3;

H4:=M5>M21;

H5:=C/REF(C,1)>1.01;

H6:=H1 AND H2 AND H3 AND H4 AND H5;

DRAWTEXT(H6,L,'☆假阴线'),COLORLIBLUE;

{日、周线同处0乖离}

K1:=M13>M34 AND M34>M55;

K2:=MA(C#WEEK,13)>MA(C#WEEK,34) AND MA(C#WEEK,34)>MA(C#WEEK,55);

K3:=C>M13*0.98 AND C
K4:=C>MA(C#WEEK,13)*0.98 AND C
K5:=K1 AND K2 AND K3 AND K4;

K6:=FILTER(K5,10);

DRAWTEXT(K6,L,'☆日、周线同处0乖离'),COLORLIBLUE;

{穿越分水岭}

L1:=COUNT(C>M55,20)<2;

L2:=REF(C,1)M55 AND CREF(C,1);

L3:=L1 AND L2;

L4:=FILTER(L3,10);

DRAWTEXT(L4,L,'☆穿越分水岭'),COLORLIBLUE;

{十全十美}

N1:=M13>M34 AND M34>M55;

N2:=REF(M13,1)>REF(M34,1) AND REF(M34,1)>REF(M55,1);

N3:="MACD.DIF">"MACD.DEA" AND "MACD.DEA">0;

N4:="MACD.MACD"
N5:=FILTER(N4,5);

N6:=CM13 AND C
N7:=N1 AND N2 AND N3 AND N5 AND N6;

DRAWTEXT(N7,L,'☆十全十美'),COLOR8080FF;

{扭转乾坤}

O1:=LAST(COUNT(C/REF(C,1)<0.95,4)>0,5,1);

O2:=C/REF(C,1)>1.07;

O3:=(V=HHV(V,6)) AND O1 AND O2;

O4:=FILTER(O3,5);

DRAWTEXT(O4,L,'☆扭转乾坤'),COLORLIBLUE;

{宝剑锋自磨砺出}

P1:=M13>M34 AND M34>M55;

P2:=REF(M13,1)>REF(M34,1) AND REF(M34,1)>REF(M55,1);

P3:=REF(C,1)2,5,1);

P4:=H>M13 AND (H-C)/REF(C,1)*100>=3 AND C>REF(C,1) AND C/REF(C,1)<1.03;

P5:=P1 AND P2 AND P3 AND P4;

P6:=FILTER(P5,5);

DRAWTEXT(P6,L,'☆扭转乾坤'),COLORLIBLUE;

{火箭冲天加速度}

R1:=COUNT(C/REF(C,1)>1.0985,3)=3;

R2:=COUNT(C/REF(C,1)>1.0985,5)=5;

R3:=R1 AND R2;

DRAWTEXT(R3,L,'☆火箭冲天加速度'),COLOR0000FF;

{万里长城}

S1:=(M13>=REF(M13,1)*0.99) OR (M13<=REF(M13,1)*1.01);

S2:=(M34>=REF(M34,1)*0.99) OR (M34<=REF(M34,1)*1.01);

S3:=(M55>=REF(M55,1)*0.99) OR (M55<=REF(M55,1)*1.01);

S4:=C/REF(C,1)>1.07 AND REF(C,1)
S5:=C>M13 AND C>M34 AND C>M55;

S6:=S1 AND S2 AND S3 AND S4 AND S5;

DRAWTEXT(S6,L,'☆不上长城非好汉'),COLORFFFFFF;

{擎天柱}

T1:=(C-O)/REF(C,1)*100;

DRAWTEXT(T1>12,L,'☆擎天柱'),COLOR800080;



版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告二

左边广告一

关闭

右边广告二

关闭