程序化指标公式
问答中心

通达信波段必备副图指标公式

通达信指标 2019-08-19阅读量:472

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作

AS:=(C*3+O+H+L)/6;
XJ:=(AS+0.618*REF(AS,1)+0.382*REF(AS,2)+0.236*REF(AS,3)+0.146*REF(AS,4))/2.382;
HLX:=EMA(HHV(XJ,3),15);
LLX:=EMA(LLV(XJ,3),15);
CH:=CROSS(XJ,HLX);CL:=CROSS(LLX,XJ);
CHH:=BARSLAST(CH);CLL:=BARSLAST(CL);
YF1:=(CHH<CLL OR CH) AND NOT(CL);
YF2:=(CHH>CLL OR CL) AND NOT(CH);
TF:=IF(YF1,LLX,HLX);
TFB:=(HLX+LLX)/2;
XJK:=SMA(EMA(XJ,3),3,1);
{程序化指标官方网址 WWW.HONGHAIE.COM}
ZWSH:=(HHV(XJ,2)+HHV(XJ,3)+HHV(XJ,4)+HHV(XJ,5))/4;
SH:=EMA(ZWSH,21);
ZWSL:=(LLV(XJ,2)+LLV(XJ,3)+LLV(XJ,4)+LLV(XJ,5))/4;
SL:=EMA(ZWSL,21);
SCH:=CROSS(XJ,SH);SCL:=CROSS(SL,XJ);
SHH:=BARSLAST(SCH);SLL:=BARSLAST(SCL);
SF1:=(SHH<SLL OR SCH) AND NOT(SCL);
SF2:=(SHH>SLL OR SCL) AND NOT(SCH);
TFS:=IF(SF1,SL,SH);
TFBS:=(SL+SH)/2;
{K线}
KX1:=(CLOSE>=OPEN) AND XJ>=TFS;
KX2:=(CLOSE<OPEN) AND XJ>=TFS;
KX3:=(CLOSE>=OPEN) AND XJ<TFS;
KX4:=(CLOSE<OPEN) AND XJ<TFS;
KX5:=((XJ>=TFS AND XJ<TF)OR (XJ<TFS AND XJ>=TF)) AND CLOSE>=OPEN;
KX6:=((XJ>=TFS AND XJ<TF)OR (XJ<TFS AND XJ>=TF)) AND CLOSE<OPEN;
DRAWBAND(TFB,RGB(40,00,40),TFS,RGB(00,00,80));
DRAWBAND(TFB,RGB(90,00,00),TF,RGB(00,55,00));
STICKLINE(KX1,C,O,2,1),COLOR4440FF;
STICKLINE(KX1,C,H,0,1),COLOR4440FF;
STICKLINE(KX1,O,L,0,1),COLOR4440FF;
STICKLINE(KX2,C,O,2,0),COLOR4440FF;
STICKLINE(KX2,O,H,0,0),COLOR4440FF;
STICKLINE(KX2,C,L,0,0),COLOR4440FF;
STICKLINE(KX3,C,O,2,1),COLORFFFF33;
STICKLINE(KX3,C,H,0,1),COLORFFFF33;
STICKLINE(KX3,O,L,0,1),COLORFFFF33;
STICKLINE(KX4,C,O,2,0),COLORFFFF33;
STICKLINE(KX4,O,H,0,0),COLORFFFF33;
STICKLINE(KX4,C,L,0,0),COLORFFFF33;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告二

左边广告一

关闭

右边广告二

关闭