程序化指标公式
问答中心

通达信量价关系副图指标公式

通达信指标 2019-09-27阅读量:437

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

量:IF(C>200,VOL/1000000,VOL/100),LINETHICK0;
亿: AMOUNT/100000000 LINETHICK0;
换手率:VOL/CAPITAL*100,LINETHICK0;
振幅:((H-L)/L)*100,LINETHICK0;
流通: CAPITAL/1000000,LINETHICK0;
业绩: FINANCE(33),LINETHICK0;
净资产: FINANCE(34),LINETHICK0;
VAR1:=HIGH-LOW; 
VAR2:=ABS(OPEN-CLOSE );
VAR3:=HIGH-IF(CLOSE>OPEN,CLOSE,O);
VAR4:=IF(CLOSE>OPEN,O,CLOSE)-LOW;
VAR5:=(VAR2/VAR1)*VOL;
VAR6:=(VAR3/VAR1)*VOL;
VAR7:=(VAR4/VAR1)*VOL;
VAR8:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))));
VAR9:=(C-MA(C,5))/MA(C,5)*100;
VAR10:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,30) AND MA(C,30)>MA(C,60);
VAR11:=MA(C,5)<MA(C,10) AND MA(C,10)<MA(C,30) ;
VAR12:=100*(1-WINNER(C)){套劳筹码};
VAR13:=100*WINNER(C){获利盘筹码};
多头:STICKLINE(C>MA(C,30),0,VOL,2,1),COLORRED;
空头:STICKLINE(C<MA(C,30),0,VOL,2,1),COLORGREEN;
上攻:STICKLINE(VAR5>=VAR6 AND VAR5>=VAR7 AND C>O,0,VAR5,2,0),COLORRED;
下攻:STICKLINE(VAR5>=VAR6 AND VAR5>=VAR7 AND C<O,0,VAR5,2,0),COLORGREEN;
上探:STICKLINE(VAR6>VAR5 AND VAR6>VAR7,0,VAR6,2,0),COLORCYAN;
下探:STICKLINE(VAR7>VAR5 AND VAR7>VAR6,0,VAR7,2,0),COLORFF6600;
相对地量:=STICKLINE( VAR8>2 AND VOL<MA(VOL,5)/2,0,VOL,2,0),COLOR00FFFF;
DRAWTEXT(VAR8>2 AND V<MA(V,5)/2,V*3,'地量'),COLOR00FFFF;
放量:STICKLINE(VOL>MA(VOL,5)*1.5,VOL,VOL+VOL*0.1,2,0),COLORWHITE;
V1:=H-L;
V2:=ABS(O-C);
V3:=H-IF(C>O,C,O);
V4:=IF(C>O,O,C)-L;
V5:=V2/V1*V;
V6:=V3/V1*V;
V7:=V4/V1*V;
M5:MA(V,5),COLORWHITE;
M10:MA(V,10),COLORYELLOW;
V8:=IF(V/CAPITAL>0.001,1,EXP(ABS(LOG(V/CAPITAL*100))));
金指:EMA(IF(L<=LLV(L,30),1,0),3)*2*V,COLORWHITE,LINETHICK2;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
RSV:=(C-LLV(L,26))/(HHV(H,26)-LLV(L,26))*100;
K:=SMA(RSV, 6, 1);
D:=SMA(K, 3, 1);
J:=3*K-2*D;
LC:=REF(C,1);
XA:=IF(CROSS(J1,J) AND J<20,-1,0)+IF(CROSS(J,J1) AND J>80,1,0);
TYP:=(H+L+C)/3;
CCJ:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))/2;
RSI1:=SMA(MAX(C-LC, 0), 6, 1)/SMA(ABS(C-LC), 6, 1)*100;
K2:=EMA((C-LLV(L,36))/(HHV(H,36)-LLV(L,36))*100, 9);
XB:=IF(CCJ>100 AND K2>50 AND C>O, 0.5, 0)+IF(RSI1>80 AND K2>50 AND C>O, 0.5, 0);
RSV3:=(C-LLV(L,100))/(HHV(H,100)-LLV(L,100))*100;
K13:=SMA(RSV3, 21, 1);
D13:=SMA(K1, 3, 1);
J13:=3*K13-2*D13;
XC:=IF(J13>80 AND RSI1>85, 0.5, 0);
警戒:V*(XA+XB+XC>0),COLOR009000,LINETHICK2;
选股:IF(V5>MA(V,5)*2 AND V5>=V6 AND V5>=V7 AND C>O OR V>MA(V,5)*3,V/2,0),COLORRED,LINETHICK2;
DRAWICON(CROSS(M5,M10),V,1);
DRAWICON(CROSS(M10,M5),V,2);
DRAWICON(CROSS(4000,金指),V,4);
DRAWICON(CROSS(M5,警戒),V,5);
{更多指标关注微信公众号:程序化指标}
DRAWTEXT(V7>V5 AND V7>V6 AND C<MA(C,30) AND V7<MA(V,5)/2 AND MA(V,5)<MA(V,10),VOL*2,'逢低跟进'),COLORMAGENTA;
DRAWTEXT(FILTER(V5>MA(V,5)*2 AND V5>=V6 AND V5>=V7 AND C>O OR V>MA(VOL,5)*3,2),1.2*V,'强势参与'),COLORRED;
DRAWTEXT(V5>=V6 AND V5>=V7 AND C<O AND V5/VOL>0.7 AND V5>MA(V,5),HHV(V,5),'空头释放'),COLORWHITE;
DRAWTEXT(V6>V5 AND V6>V7 AND C>MA(C,5) AND C>MA(C,34) AND H>MA(C,55) AND V>M5 AND V6>MA(V,5),V,'逢高出货'),COLORGREEN;
低量:FINANCE(7)/5000,LINETHICK1,COLORBLUE,POINTDOT;
活跃量:FINANCE(7)/1000,LINETHICK1,COLORYELLOW,POINTDOT;
危险成交量:FINANCE(7)/500,LINETHICK1,COLORRED,POINTDOT;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告二

左边广告一

关闭

右边广告二

关闭