程序化指标公式
问答中心

通达信平步青云主图指标公式

通达信指标 2019-10-04阅读量:1446

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

CXHZB:EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),COLORRED,LINETHICK1;
Y1M:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48);
AA:=EMA((CLOSE+HIGH+LOW)/3,3)>=CXHZB;
DRAWICON(CROSS(AA,0.5),L,1);{微信公众号:程序化指标}
IF(EMA((CLOSE+HIGH+LOW)/3,3)>=CXHZB,CXHZB,DRAWNULL),DOTLINE,COLORRED;
IF(EMA((CLOSE+HIGH+LOW)/3,3)<=CXHZB,CXHZB,DRAWNULL),DOTLINE,COLORGREEN;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)>=CXHZB,LOW,HIGH,0,0),COLORRED;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)>=CXHZB,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)<=CXHZB,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)<=CXHZB,CLOSE,OPEN,3,1),COLORGREEN;
MACD1:=EMA(CLOSE,3) - EMA(CLOSE,9);
DEA1:=EMA((EMA(MACD1,102) - EMA(MACD1,204)),9);
DEA2:=EMA((EMA(MACD1,51) - EMA(MACD1,102)),9);
DEA3:=EMA((EMA(MACD1,36) - EMA(MACD1,72)),9);
DEA4:=EMA((EMA(MACD1,24) - EMA(MACD1,48)),9);
DEA5:=EMA((EMA(MACD1,18) - EMA(MACD1,36)),9);
DEA6:=EMA((EMA(MACD1,6) - EMA(MACD1,12)),9);
DEA7:=EMA((EMA(MACD1,3) - EMA(MACD1,9)),9);
DEA8:=EMA((EMA(MACD1,12) - EMA(MACD1,24)),9);
MACD2:=2*((EMA(MACD1,24) - EMA(MACD1,48))-DEA4);
HH1:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL1:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H1:=EMA(HH1,90),COLORRED,LINETHICK1;
D90L1:=EMA(LL1,90),COLORRED,LINETHICK1;
D901:=(D90H1+D90L1)/2;
DRAWTEXT_FIX(CURRBARSCOUNT=120,0.7,0.01,0,'【微信公众号:程序化指标 】'),COLORGREEN;
CCI1:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,15))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,15));
CCI2:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,10))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,10));
CCI3:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,5))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,5));
CCI4:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,3))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,3));
买点定位1:=CROSS(CCI3,0) AND CROSS(CCI4,0) AND REF(CCI1,1)>0 AND REF(CCI2,1)>-30 AND REF(CCI1,1)>REF(CCI2,1) AND REF(CCI2,1)>REF(CCI3,1);
买点定位2:=CROSS(CCI4,0) AND CCI3>REF(CCI3,1) AND REF(CCI3,1)<-100 AND REF(CCI1,1)>0 AND REF(CCI2,1)>-30 AND REF(CCI1,1)>REF(CCI2,1) AND REF(CCI2,1)>REF(CCI3,1);
买点定位3:=CROSS(CCI3,0) AND CROSS(CCI4,0) AND REF(CCI2,1)>0 AND REF(CCI2,1)>REF(CCI1,1);
买点定位:=买点定位1=1 OR 买点定位2=1 OR 买点定位3=1;
VOL1:=VOL/REF(VOL,1);
平步青云:=买点定位 AND VOL1>1.2;
STICKLINE(平步青云,O,C,3,0),COLOR2CB3E3;
DRAWTEXT(平步青云 ,L*0.98,'平步青云')COLORYELLOW;
DRAWICON(平步青云,L*0.99,1);

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭