程序化指标公式
问答中心

通达信出手抓牛主图指标公式

通达信指标 2019-10-30阅读量:372

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

DRAWRECTREL(0,0,200,480,RGB(25,55,144));
DRAWTEXT_FIX(DYNAINFO(39)<100,0.01,0.0,0,STRCAT('动态市盈率:',CON2STR(DYNAINFO(39),2))),COLORMAGENTA;
DRAWTEXT_FIX(DYNAINFO(39)>100,0.01,0.0,0,STRCAT('动态市盈率:',CON2STR(DYNAINFO(39),2))),COLORGREEN;
DRAWTEXT_FIX(FINANCE(40)/100000000<10,0.01,0.05,0,STRCAT('流通市值(亿): ',CON2STR(FINANCE(40)/100000000,2))),COLORMAGENTA;
DRAWTEXT_FIX(FINANCE(40)/100000000>10,0.01,0.05,0,STRCAT('流通市值(亿): ',CON2STR(FINANCE(40)/100000000,2))),COLORGREEN;
DRAWTEXT_FIX(FINANCE(11)/FINANCE(15)>1.2,0.01,0.10,0,STRCAT('流动比例: ',CON2STR(FINANCE(11)/FINANCE(15),1))),COLORMAGENTA;
DRAWTEXT_FIX(FINANCE(11)/FINANCE(15)<=1.2,0.01,0.10,0,STRCAT('流动比例: ',CON2STR(FINANCE(11)/FINANCE(15),1))),COLORGREEN;
DRAWTEXT_FIX((FINANCE(11)-FINANCE(27))/FINANCE(15)>1.2,0.01,0.15,0,STRCAT('速动比例:',CON2STR((FINANCE(11)-FINANCE(27))/FINANCE(15),1))),COLORMAGENTA;
DRAWTEXT_FIX((FINANCE(11)-FINANCE(27))/FINANCE(15)<=1.2,0.01,0.15,0,STRCAT('速动比例:',CON2STR((FINANCE(11)-FINANCE(27))/FINANCE(15),1))),COLORGREEN;
DRAWTEXT_FIX(FINANCE(9)<45,0.01,0.20,0,STRCAT('资产负债率: ',CON2STR(FINANCE(9),2))),COLORMAGENTA;
DRAWTEXT_FIX(FINANCE(9)>=45,0.01,0.20,0,STRCAT('资产负债率: ',CON2STR(FINANCE(9),2))),COLORGREEN;
DRAWTEXT_FIX(FINANCE(34)>2,0.01,0.25,0,STRCAT('每股净资产: ',CON2STR(FINANCE(34),2))),COLORRED;
DRAWTEXT_FIX(FINANCE(34)<=2,0.01,0.25,0,STRCAT('每股净资产: ',CON2STR(FINANCE(34),2))),COLORGREEN;
DRAWTEXT_FIX(FINANCE(43)>1,0.01,0.30,0,STRCAT('利润同比:',CON2STR(FINANCE(43),2))),COLORRED;
DRAWTEXT_FIX(FINANCE(43)<1,0.01,0.30,0,STRCAT('利润同比:',CON2STR(FINANCE(43),2))),COLORCYAN;
DRAWTEXT_FIX(FINANCE(44)>1,0.01,0.35,0,STRCAT('收入同比:',CON2STR(FINANCE(44),2))),COLORRED;
DRAWTEXT_FIX(FINANCE(44)<1,0.01,0.35,0,STRCAT('收入同比:',CON2STR(FINANCE(44),2))),COLORCYAN;
DRAWTEXT_FIX(FINANCE(8)>10000,0.01,0.40,0,STRCAT('股东人数:',CON2STR(FINANCE(8),0))),COLORLIRED;
DRAWTEXT_FIX(FINANCE(8)<=10000,0.01,0.40,0,STRCAT('股东人数:',CON2STR(FINANCE(8),0))),COLORGREEN;
动力线:MA(C,5),LINETHICK3,COLOR00CCFF;
牛熊线:MA(C,13),CIRCLEDOT,COLORYELLOW;
生命线:MA(C,34),CIRCLEDOT,COLORMAGENTA;
MA05:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;{需要编写选股关注微信公众号:程序化指标}
VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'◆加二'),COLORYELLOW;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'◆风险'),COLORCYAN;
DRAWTEXT(买入,LOW*0.96,'◆买二'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.00,'◆清仓'),COLORGREEN;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46; 
{彩色K线}
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED; 
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44; 
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF; 
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF; 
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF; 
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD; 
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
{涨跌停K线}
STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (CLOSE/REF(CLOSE,1))>1.048,HIGH,LOW,3,0) ,COLORRED;
STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (REF(CLOSE,1)/CLOSE)>1.048,HIGH,LOW,3,0) ,COLOR00FF00;
{突破}
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
{买卖主图}
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW,'★买一'),COLORRED;
加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(加1,LOW*0.99,'★加一'),COLORCC66FF;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★卖一'),COLORGREEN;
{牛熊通吃}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.99,'老鼠仓'),COLOR4080FF;
{预测明天}
XXS:=MA(LOW,5)*(1-5/100); 
XXS1:=MA(HIGH,5)*(1+5/100); 
均线:=C,COLORGREEN; 
AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ; 
DRAWTEXT(AAAA,L*0.95,'下影买'),COLORRED; 
BBAA:=CROSS(XXS1,C); 
DRAWTEXT(CROSS(XXS1,C),H,'开盘逃'),COLORWHITE; 
DDDD:=CROSS(C,XXS1); 
DRAWTEXT(DDDD,H,'明日走'),COLORYELLOW; 


版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭