程序化指标公式
问答中心

通达信底部三部曲副图指标公式

通达信指标 2019-11-04阅读量:347

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

UPPER:(1+11/100)*MA(CLOSE,10),COLORGREEN,LINETHICK2;

IF(UPPER>=REF(UPPER,1),UPPER,DRAWNULL),COLORRED,LINETHICK3;

IF(UPPER<=REF(UPPER,1),UPPER,DRAWNULL),COLORGREEN,LINETHICK2;

LOWER:(1-9/100)*MA(CLOSE,10),COLORGREEN,LINETHICK2;

IF(LOWER>=REF(LOWER,1),LOWER,DRAWNULL),COLORRED,LINETHICK3;

IF(LOWER<=REF(LOWER,1),LOWER,DRAWNULL),COLORGREEN,LINETHICK2;

ENE:(UPPER+LOWER)/2,COLORGREEN,LINETHICK2;

IF(ENE>=REF(ENE,1),ENE,DRAWNULL),COLORRED,LINETHICK3;

IF(ENE<=REF(ENE,1),ENE,DRAWNULL),COLORGREEN,LINETHICK2;

DRAWTEXT_FIX(1,0.02,0,0,'☆微信公众号:(程序化指标) ☆'),COLORRED;

XA_1:=ABS(((3.48*CLOSE+HIGH+LOW+OPEN)/5-EMA(CLOSE,20))/EMA(CLOSE,20));

XA_2:=DMA((2.15*CLOSE+LOW+HIGH+OPEN)/5,XA_1);

XA_3:=EMA(XA_2,200)*1.26;

XA_4:=EMA(XA_2,200)*1.18;

XA_5:=MA((LOW+HIGH+CLOSE)/3,5);

XA_6:=HHV(XA_5,60);

XA_7:=IF(XA_6>REF(XA_6,1),XA_6,DRAWNULL);

XA_8:=CLOSE*VOL;

XA_9:=EMA((EXPMA(XA_8,3)/EXPMA(VOL,3)+EXPMA(XA_8,6)/EXPMA(VOL,6)+EXPMA(XA_8,12)/EXPMA(VOL,12)+EXPMA(XA_8,24)/EXPMA(VOL,24))/4,13);

上轨:1.06*XA_9,COLORBLACK;

顶:1.13*XA_9,COLORWHITE,LINETHICK3;

XA_10:=MIN(XA_7,XA_3);

XA_11:=MIN(上轨,XA_3);

XA_12:=MIN(XA_7,XA_4);

XA_13:=MIN(上轨,XA_4);

XA_14:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;

XA_15:=CROSS(CLOSE,上轨) AND XA_14;

{DRAWTEXT(XA_15,LOW*0.85,1),COLORYELLOW;}

DRAWICON(XA_15,LOW*0.86,13);

XA_16:=CROSS(CLOSE,顶) AND XA_14;

{DRAWICON(XA_16,LOW*0.8,5);

DRAWTEXT(XA_16,LOW*0.8,1),COLORYELLOW;}

XA_17:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);

STICKLINE(XA_17,OPEN,CLOSE,4,0),COLORRED;

STICKLINE(XA_17,OPEN,CLOSE,3,0),COLORYELLOW;

STICKLINE(XA_17,HIGH,LOW,0,0),COLORYELLOW;

XA_18:=DMA(AMOUNT/(89*VOL),VOL/CAPITAL);

XA_19:=CLOSE>REF(HHV(CLOSE,89),1);

XA_20:=DMA(AMOUNT/(89*VOL),VOL/CAPITAL);

XA_21:=CROSS(CLOSE,XA_20) AND XA_19;

{DRAWTEXT(XA_21,LOW*0.99,2),COLORRED;

DRAWTEXT(XA_21,LOW*0.99,3),COLORBLACK;}

STICKLINE(XA_21,CLOSE,OPEN,3.2,0),COLOR0077FF;

STICKLINE(XA_21,CLOSE,OPEN,2.5,0),COLOR0099FF;

STICKLINE(XA_21,CLOSE,OPEN,1.9,0),COLOR00BBFF;

STICKLINE(XA_21,CLOSE,OPEN,1.2,0),COLOR00DDFF;

STICKLINE(XA_21,CLOSE,OPEN,0.3,0),COLORYELLOW;

XA_22:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));

XA_23:=DMA((2.15*CLOSE+LOW+HIGH)/4,XA_22);

XA_24:=EMA(XA_23,200)*1.118;

XA_25:=EMA(XA_23,200)*1.118;

XA_26:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>8;

XA_27:=CROSS(CLOSE,XA_24) AND XA_26;

{DRAWTEXT(XA_27,LOW*0.98,2),COLORRED;

DRAWTEXT(XA_27,LOW*0.98,4),COLORYELLOW;}

STICKLINE(XA_27,CLOSE,OPEN,3.2,0),COLOR0077FF;

STICKLINE(XA_27,CLOSE,OPEN,2.5,0),COLOR0099FF;

STICKLINE(XA_27,CLOSE,OPEN,1.9,0),COLOR00BBFF;

STICKLINE(XA_27,CLOSE,OPEN,1.2,0),COLOR00DDFF;

STICKLINE(XA_27,CLOSE,OPEN,0.3,0),COLORYELLOW;

XA_28:=EMA((EXPMA(XA_8,23)/EXPMA(VOL,23)+EXPMA(XA_8,54)/EXPMA(VOL,54)+EXPMA(XA_8,108)/EXPMA(VOL,108)+EXPMA(XA_8,316)/EXPMA(VOL,316))/4,34);

XA_29:=1.0668*XA_28;

XA_30:=CROSS(CLOSE,XA_29) AND REF(CLOSE,1)*1.08-CLOSE<0.008 AND CLOSE>OPEN*0.5;

DRAWICON(XA_30,LOW*0.98,13);

{DRAWTEXT(XA_30,LOW*0.98,1),COLORYELLOW;}

XA_31:=XA_21 AND XA_27;

DRAWICON(XA_31,LOW*0.95,13);

{DRAWTEXT(XA_31,LOW*0.96,1),COLORYELLOW;}

XA_32:=CROSS(CLOSE,XA_24) AND XA_26;

DRAWICON(XA_32,LOW*0.92,13);

{DRAWTEXT(XA_32,LOW*0.94,1),COLORYELLOW;}

MA3:=MA(CLOSE,3);

MA5:=MA(CLOSE,5);

MA7:=MA(CLOSE,7);

MA10:=MA(CLOSE,10);

MA15:=MA(CLOSE,15);

MA20:=MA(CLOSE,20);

MA25:=MA(CLOSE,25);

MA30:=MA(CLOSE,30);

MA45:=MA(CLOSE,45);

MA60:=MA(CLOSE,60);

MA90:=MA(CLOSE,90);

MA120:=MA(CLOSE,120);

MA160:=MA(CLOSE,160);

MA200:=MA(CLOSE,200);

MA250:=MA(CLOSE,200);

HJ26:=SUM(C,H) AND H>L;

FHJ1:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MA3,MA5),MA7),MA10),MA15),MA20),MA25),MA30),MA45),MA60),MA90),MA120),MA160),MA200),MA250);

FHJ2:=MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MA3,MA5),MA7),MA10),MA15),MA20),MA25),MA30),MA45),MA60),MA90),MA120),MA160),MA200),MA250); 

三与250乖率:MA3/MA250*100-100,COLORMAGENTA,NODRAW;

所有线乖率:FHJ1/FHJ2*100-100,COLORYELLOW,NODRAW;

涨停基因:(CONST(BARSCOUNT(CLOSE)))/(COUNT(HJ26,BARSSINCE(HJ26)+1)),NODRAW,COLORRED;

GP:=NAMELIKE('S') OR NAMELIKE('*');

HJ28:=IF(GP,REF(C,1)*1.05,REF(C,1)*1.1);

HJ29:=IF(HJ28,REF(C,1)*1.05,REF(C,1)*1.1);

DRAWTEXT_FIX(1,0.95,1,1,STRCAT('涨停:',CON2STR(HJ28,2))),COLORRED;

明涨停价:REF(C,H),NODRAW,COLOR0080FF;

流通市值:(FINANCE(40)/100000000),NODRAW,COLORCYAN;

融资融券股:IF(FINANCE(52)>0,100,DRAWNULL),COLORGRAY,NODRAW;

XZ_1:=ABS(((3.48*CLOSE+HIGH+LOW+OPEN)/5-EMA(CLOSE,20))/EMA(CLOSE,20));

XZ_2:=DMA((2.15*CLOSE+LOW+HIGH+OPEN)/5,XZ_1);

XZ_3:=EMA(XZ_2,200)*1.26;

XZ_4:=EMA(XZ_2,200)*1.18;

XZ_5:=MA((LOW+HIGH+CLOSE)/3,5);

XZ_6:=HHV(XZ_5,60);

XZ_7:=IF(XZ_6>REF(XZ_6,1),XZ_6,DRAWNULL);

XZ_8:=CLOSE*VOL;

XZ_9:=EMA((EXPMA(XZ_8,3)/EXPMA(VOL,3)+EXPMA(XZ_8,6)/EXPMA(VOL,6)+EXPMA(XZ_8,12)/EXPMA(VOL,12) + EXPMA (XZ_8,24)/ EXPMA( VOL,24 ) )/4 , 13 ) ;

XZ_10:=1.03*XZ_9;

XZ_11:=1.13*XZ_9;

XZ_12:=MIN(XZ_7,XZ_3);

XZ_13:=MIN(XZ_10,XZ_3);

XZ_14:=MIN(XZ_7,XZ_4);

XZ_15:=MIN(XZ_10,XZ_4);

XZ_16:=CLOSE/REF(CLOSE,1)>1.03 AND CLOSE=HIGH;

XZ_17:=CROSS(CLOSE,XZ_11) AND XZ_16;

DRAWICON(XZ_17,LOW*0.86,5);

DRAWTEXT(XZ_17,LOW*0.86,' 90%吃肉'),COLORYELLOW;


版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭