程序化指标公式
问答中心

通达信启动点主图指标公式

通达信指标 2020-08-10阅读量:628

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

N:=30;
M:=13;
顶1:=REFDATE(HHV(H,M),DATE);
底1:=REFDATE(LLV(L,M),DATE);
H1:=顶1-(顶1-底1)*0.191;
H2:=顶1-(顶1-底1)*0.382;
H3:=顶1-(顶1-底1)*0.5;
H4:=顶1-(顶1-底1)*0.618;
H5:=顶1-(顶1-底1)*0.809;{需要编写选股关注微信公众号:程序化指标}
顶部:IF(CURRBARSCOUNT<=N,REFDATE(顶1,DATE),DRAWNULL),COLORGREEN,DOTLINE;
%61_8:IF(CURRBARSCOUNT<=N,REFDATE(H4,DATE),DRAWNULL),COLORBROWN,DOTLINE;
底部:IF(CURRBARSCOUNT<=N,REFDATE(底1,DATE),DRAWNULL),COLORCYAN,DOTLINE;
DRAWTEXT(CURRBARSCOUNT=30,顶部*0.99,' 实顶'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=30,%61_8*0.99,' 高抛低吸'),COLORBROWN;
DRAWTEXT(CURRBARSCOUNT=30,底部*0.99,' 启动点'),COLORCYAN;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14
*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8
*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
马线:MA(牛线,6),COLORGREEN;
DRAWBAND(马线,RGB(0,139,139),牛线,RGB(255,105,180));
DRAWICON(CROSS(牛线,马线),马线*0.98,42);
MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORYELLOW;
MA30:MA(C,30),COLORMAGENTA;
MA60:MA(C,60),COLORGREEN;
MA120:MA(C,120),COLORBLUE;
VAR0:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
DRAWTEXT(CROSS(82,VAR0),L*1.0,'←跑'),COLORWHITE;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWICON(CROSS(84,JH),H*1.02,6);
字:=STRCAT(STRCAT(STRCAT(STRCAT('名称: ',STKNAME),' 代码: '),CODE),' ' );
板块:=STRCAT('概念板块: ',GNBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(字,板块)),COLORYELLOW;
YC:=REF(CLOSE,1);
止损价位:=(YC*1.0035*97+0.2)/99.65;
DRAWTEXT_FIX(C!=0,0.2,0.1,0,STRCAT('止损价位 ',STRCAT(CON2STR(止损价位,2),' 元'))),COLORBLUE;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);{需要编写选股关注微信公众号:程序化指标}
DRAWTEXT_FIX(C!=0,0,0.05,0,STRCAT('今日阻力: ',STRCAT(CON2STR(今日阻力,2),' 元'))),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0,0.1,0,STRCAT('今日支撑: ',STRCAT(CON2STR(今日支撑,2),' 元'))),COLORRED;
DRAWTEXT_FIX(C!=0,0,0.15,0,STRCAT('明日突破: ',STRCAT(CON2STR(明日突破,2),' 元'))),COLORFF00FF;
DRAWTEXT_FIX(C!=0,0,0.2,0,STRCAT('明日阻力: ',STRCAT(CON2STR(明日阻力,2),' 元'))),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0,0.25,0,STRCAT('明日支撑: ',STRCAT(CON2STR(明日支撑,2),' 元'))),COLORRED;
DRAWTEXT_FIX(C!=0,0,0.3,0,STRCAT('明日反转: ',STRCAT(CON2STR(明日反转,2),' 元'))),COLORYELLOW;
DRAWTEXT_FIX(1,0.15,0.15,0,STRCAT('【风格:',STRCAT(FGBLOCK,'】'))),COLORWHITE;
A:=HHV(HIGH,13)=HIGH AND HIGH>REF(HIGH,1);
A1:=FILTER(A,12);
B:=LLV(LOW,13)=LOW AND LOW<REF(LOW,1);
B1:=FILTER(B,12);
TS1:=BARSLAST(A1);
箱顶:REF(HIGH,TS1),COLORFF00FF,NODRAW;
STICKLINE(1,箱顶,箱顶,1.5,0),COLOR00CCCC;
TS2:=BARSLAST(B1);
箱底:REF(LOW,TS2),COLORWHITE,NODRAW;
STICKLINE(1,箱底,箱底,2,0),COLORWHITE;
箱高:100*(箱顶-箱底)/箱底,NODRAW;
均价:=(3*C+H+L+O)/6;
VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+
4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;
SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;
SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;
SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND CLOSE>VAR2 AND CLOSE<VAR1;
SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)
AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1)
AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);
SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;
XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)
AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);
XD2:=VAR1=VAR2 AND CLOSE>VAR1;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:=IF(SAT>1,1,SAT)*100;
程序化指标:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)<20;
DRAWTEXT(程序化指标,C,'庄仓'),COLORYELLOW;
STICKLINE(程序化指标,O,C,1.5,0),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ1,0.5,0.05,0,'调整结束短线介入'),COLORRED;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ2,0.5,0.05,0,'上升通道走势良好'),COLORRED;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ3,0.5,0.05,0,'股价偏离注意调整'),COLORRED;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ4,0.5,0.05,0,'上升通道调整洗盘'),COLORGREEN;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ5,0.5,0.05,0,'转向特征注意离场'),COLORGREEN;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ6,0.35,0.05,0,'通道改变坚决离场'),COLORGREEN;
DRAWTEXT_FIX(BARSTATUS=2 AND XD1,0.5,0.05,0,'下跌通道只宜观望'),COLORGREEN;
DRAWTEXT_FIX(BARSTATUS=2 AND XD2,0.5,0.05,0,'短期底部准备进入'),COLORYELLOW;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭