程序化指标公式
问答中心

大智慧背离主升主图指标公式

大智慧公式 2019-06-02阅读量:662
安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击  安装指南  步骤操作

MA10:MA(C,10),COLORWHITE;
MA20:MA(C,20),COLORYELLOW;
MA40:MA(C,40),COLORRED;
MA60:MA(C,60),COLORGREEN;
{程序化指标官方网址 www.honghaie.com}
MA120:MA(C,120),COLORE66878;
MA250:MA(C,250),COLORFF937F;
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:=(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210;
HHJSJDC:=MA(HHJSJDB,5);
STICKLINE(HHJSJDB>HHJSJDC,HHJSJDB,HHJSJDC,10,0),COLORYELLOW;
STICKLINE(HHJSJDC>HHJSJDB,HHJSJDB,HHJSJDC,10,0),COLORBLUE;
MA21:=EMA(CLOSE,21);
MID:=MA(CLOSE,21);
风险线:= MA(CLOSE,13);
止损线:= MA(CLOSE,27);
牛熊线:=EMA(C,250);
界:=MA(CLOSE,21);
DRAWTEXT(CROSS(MA10,界),(LOW * 0.80),'◇底背离'),COLORWHITE;
DRAWTEXTABS(5,5,'每次都抓主升浪'),linethick1,COLOR00EEff;
DRAWTEXT(CROSS(C,止损线)AND 止损线>风险线,(LOW * 0.96),'主升浪'),COLORRED,LINETHICK3;
DK:=MA(((SLOPE(C,20)*5)+C),20);
STICKLINE(DK<=C AND CLOSE>=OPEN,HIGH,LOW,0.1,1),COLORRED;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(DK<=C AND CLOSE<OPEN,HIGH,LOW,0.1,0),COLORRED;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,3,0),COLORRED;
STICKLINE(DK>C AND CLOSE>=OPEN,HIGH,LOW,0.1,1),COLORGREEN;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,3,1),COLORGREEN;
STICKLINE(DK>C AND CLOSE<OPEN,HIGH,LOW,0.1,0),COLORGREEN;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,3,0),COLORGREEN;
DRAWTEXT(CROSS(C,DK),LOW*0.99,'★B'),COLORMAGENTA;
DRAWTEXT(CROSS(DK,C),H*1.01,'☆S'),COLORYELLOW;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45上升'),COLORWHITE;
BEGIN DRAWTEXTREL(0,10,'所属板块:'+BKNAME),LINETHICK1,ColorF7F700;end;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWTEXTREL(800,100,'量能饱和度:'+NUMTOSTRN(SAT,0)),LINETHICK2,Color00FBFB;
DD:=FINANCE2(35)/10000;
SS:=FINANCE2(37)/10000;
GG:=FINANCE2(3);
TH:=DYNAINFO(39);{程序化指标官方网址 www.honghaie.com}
DRAWTEXTABS(0,20,'总股本:'+NUMTOSTRn(DD,2)+'亿股' +'  流通A股:'+NUMTOSTRn(SS,2)+'亿股'+'  市盈率:'+NUMTOSTRn(TH,2)+' 倍'+'  每股收益:'+NUMTOSTRn(GG,3)+' 元'),ColorF7F700;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭