程序化指标公式
问答中心

同花顺波段阶梯副图指标公式

同花顺公式 2019-06-23阅读量:587

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击  安装指南 步骤操作

VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);//程序化指标官方网址 www.honghaie.com
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
VAR18:=EMA(VAR17,5);
STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1), ,colorred ;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1), ,colorblue ;//程序化指标官方网址 www.honghaie.com
VAR1A:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR2A:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VAR3A:=SMA(SMA(VAR2A,3,1),3,1);
VAR4A:=EMA(VAR3A,5);
VAR5A:=LLV(LOW,26);
VAR6A:=HHV(HIGH,34);
VAR7A:=EMA((CLOSE-VAR5A)/(VAR6A-VAR5A)*4,4)*25;
VAR8A:=(2*C+H+L)/4;
VAR9A:=LLV(LOW,9);
VAR10A:=HHV(HIGH,9);
VAR2W:=100-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
MW:= EMA(VAR2W,3);
VAR3W:=EMA(VAR2W,7);
M1:= EMA(VAR3W,5);
MB1:=CROSS(MW,M1) AND M1<20;
MG1:=IF(CROSS(M1,MW) AND REF(MW,1)>80,80 ,0) ;
波段:=EMA((VAR8A-VAR9A)/(VAR10A-VAR9A)*100,9),colorred;
B1:=EMA(0.667*REF(波段,1)+0.333*波段,2),COLOR00FF00;
STICKLINE(波段>B1,波段,B1,10,1),colorlimagenta;
STICKLINE(波段<=B1,波段,B1,10,1),COLOR00FF00;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭