程序化指标公式
问答中心

同花顺启动与回调副图指标公式

同花顺公式 2020-06-14阅读量:470

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作

VAR2:=EMA(SLOPE(EMA(CLOSE,20),10)*34+CLOSE,30);

VAR3:=EMA(VAR2,3);

VAR4:=EMA(VAR3,3);

VAR5:=EMA(VAR4,3);

VAR6:=EMA(VAR5,3);

VA7:=EMA(VAR6,3);

VAR7:=EMA(VA7,3);

VA8:=EMA(VAR7,3);

VAR8:=EMA(VA8,3);

VAR9:=EMA(VAR8,3);

VARA:=BARSLAST(CROSS(CLOSE,VAR9));

VARB:=BARSLAST(CROSS(VAR9,CLOSE));

DRAWTEXT_FIX(1,0.72,0,0,'☆微信公众号:(程序化指标) ☆'),colorred;

启动位:IF(CLOSE>VAR9 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA)),colorred,POINTDOT,LINETHICK3;

DRAWTEXT(ISLASTBAR AND 启动位,启动位,'____【升浪启动位】'),colorred;

DRAWNUMBER(ISLASTBAR AND 启动位,启动位,启动位),colorred;

STICKLINE(CLOSE>VAR9 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1,5,0),colorred,LINETHICK2;

强:=IF(CLOSE<VAR9 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),REF(CLOSE,VARB)),colorred,POINTDOT,LINETHICK1;

STICKLINE(CLOSE<VAR9 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),HIGH*1,5,0),colorgreen,LINETHICK2;

势:=IF(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA)),coloryellow,POINTDOT;

STICKLINE(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1.02,6,0),colorligray;

回调位:IF(CLOSE<VAR9,REF(CLOSE,VARB),REF(CLOSE,VARB)),colorliblue,POINTDOT,LINETHICK3;

DRAWTEXT(ISLASTBAR AND 回调位,回调位,'____回调位'),colorliblue;

DRAWNUMBER(ISLASTBAR AND 回调位,回调位,回调位),colorliblue;

STICKLINE(CLOSE<VAR9,REF(CLOSE,VARB),REF(CLOSE,VARB),16,0),colorliblue,LINETHICK5;

STICKLINE(CLOSE>VAR9,REF(CLOSE,VARA),REF(CLOSE,VARA),16,0),colorred,LINETHICK5;

STICKLINE(C>=O,H,L,0,0),colormagenta,LINETHICK2;

MA1:=MA(C,1);

启动比:(MA1-启动位)/启动位*100,coloryellow,nodraw;

回调比:(MA1-回调位)/回调位*100,colorgreen,nodraw;C3:=REF(C,1);

涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),Color2DFFFF;

STICKLINE(涨停,OPEN,CLOSE,10,0),Color008C8C;

STICKLINE(涨停,OPEN,CLOSE,8,0),Color00AAAA;

STICKLINE(涨停,OPEN,CLOSE,6,0),Color00CACA;

STICKLINE(涨停,OPEN,CLOSE,5,0),Color00E3E3;

STICKLINE(涨停,OPEN,CLOSE,4,0),Color02FFFF;

STICKLINE(涨停,OPEN,CLOSE,3,0),Color02FFFF;

STICKLINE(涨停,OPEN,CLOSE,2,0),Color2DFFFF;

STICKLINE(涨停,OPEN,CLOSE,1,0),Color2DFFFF;

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),Color33FF33;

STICKLINE(跌停,OPEN,CLOSE,10,0),Color009B00;

STICKLINE(跌停,OPEN,CLOSE,8,0),Color00B700;

STICKLINE(跌停,OPEN,CLOSE,6,0),Color00D200;

STICKLINE(跌停,OPEN,CLOSE,5,0),Color00EA00;

STICKLINE(跌停,OPEN,CLOSE,4,0),Color0FFF0F;

STICKLINE(跌停,OPEN,CLOSE,3,0),Color0FFF0F;

STICKLINE(跌停,OPEN,CLOSE,2,0),Color33FF33;

STICKLINE(跌停,OPEN,CLOSE,1,0),Color33FF33;

ZT:=C/REF(C,1)>1.097;

BH:=BARSLAST(ZT);

STICKLINE(C,REF(L,BH),REF(L,BH),15,0),colorligray,LINETHICK1;

涨停启动位:=C,REF(L,BH),REF(L,BH);

DRAWTEXT(ISLASTBAR AND 涨停启动位,涨停启动位,'____【启动涨停位】'),colorligray;

DRAWNUMBER(ISLASTBAR AND 涨停启动位,涨停启动位,涨停启动位),colorwhite;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告一

右边广告二

关闭