程序化指标公式
问答中心

同花顺多空PK波段副图指标公式

同花顺公式 2019-05-31阅读量:679

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击  安装指南  步骤操作

VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
 VAR3:=(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+
 12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)
 +4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210;
 VAR4:=MA(VAR3,13);
 VAR5:=EMA(MA(CLOSE,3),34);
 VAR6:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
 VAR7:=MA(VAR6,5);
 VAR8:=MA(VAR6,10);
 STICKLINE(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4),VAR3,VAR4,10,1),COLOR006600 ;
 STICKLINE(VAR3>1.005*VAR4,VAR3,VAR4,10,1),COLORFF00FF;
 DRAWTEXT(FILTER(MA(VAR6,10)<VAR7,1),VAR8,'↑'),COLORRED;
 DRAWTEXT(FILTER(MA(VAR6,10)>=VAR6,1),VAR8,'↓'),COLOR00FF00;
 多空安全线: VAR5,COLORWHITE;
 〖关注点〗: STICKLINE(COUNT(VAR3>1.005*VAR4 AND VAR3<=REF(VAR3,1),2)=2 OR
 COUNT(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4) AND VAR3>=REF(VAR3,1),2)=2,VAR3,VAR4,10,0),COLORYELLOW;
DRAWTEXT(REF(CROSS(VAR3,VAR4),2) AND VAR3>1.005*VAR4,VAR4,'★买入点'),COLORWHITE;
 DRAWTEXT(CROSS(VAR6,VAR7) AND VAR7<VAR8,VAR3*0.95,'▲多空争夺'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=120,0.4,0.01,0,'【微信公众号:(程序化指标)    官方网址:WWW.HONGHAIE.COM 】'),COLORGREEN;
 VAR9:=1/WINNER(CLOSE);
 VARA:=MA(CLOSE,13);
 VARB:=100-ABS((CLOSE-VARA)/VARA*100);
 VARC:=LLV(LOW,75);
 VARD:=HHV(HIGH,75);
 VARE:=(VARD-VARC)/100;
 VARF:=SMA((CLOSE-VARC)/VARE,20,1);
 VAR10:=SMA((OPEN-VARC)/VARE,20,1);
 VAR11:=3*VARF-2*SMA(VARF,15,1);
 VAR12:=3*VAR10-2*SMA(VAR10,15,1);
 VAR13:=100-VAR12;
 VAR14:=100-VAR11;
 VAR15:=MA(WINNER(CLOSE*0.95)*100,3);
 VAR16:=100-IF(VAR9>5,IF(VAR9<100,VAR9,VARB-10),0);
 VAR17:=VAR15>VARB;
 VAR18:=REF(LOW,1)*0.9;
 VAR19:=LOW*0.9;
 VAR1A:=(VAR19*VOL+VAR18*(CAPITAL-VOL))/CAPITAL;
 VAR1B:=EMA(VAR1A,30);
 VAR1C:=CLOSE-REF(CLOSE,1);
 VAR1D:=MAX(VAR1C,0);
 VAR1E:=ABS(VAR1C);
 VAR1F:=SMA(VAR1D,7,1)/SMA(VAR1E,7,1)*100;
 VAR20:=SMA(VAR1D,13,1)/SMA(VAR1E,13,1)*100;
 VAR21:=BARSCOUNT(CLOSE);
 VAR22:=SMA(MAX(VAR1C,0),6,1)/SMA(ABS(VAR1C),6,1)*100;
 VAR23:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
 VAR24:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
 VAR25:=SMA((SMA(VAR24,4,1)-50)*2,3,1);
 VAR26:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
 VAR27:=SMA(VAR26,4,1);
 VAR28:=SMA(VAR27,3,1);
 VAR29:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
 VAR2A:=VAR22<=25 AND VAR23<-95 AND VAR29>20 AND VAR25<-30 AND VAR28<30 AND VAR1B-CLOSE>=-0.25 AND VAR1F<22 AND VAR20<28
 AND VAR21>50;
 DRAWTEXT(CROSS(VAR2A,0.5) AND COUNT(VAR2A=1,10)=1,VAR4,'发射资金'),COLORRED;
 DRAWTEXT(CROSS(VAR17,0.5) AND COUNT(VAR17=1,10)=1,VAR3,'激烈交锋'),COLORWHITE;
 VAR326:=IF(CLOSE>REF(CLOSE, 1),88,0);
 VAR327:=CLOSE/REF(CLOSE, 1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0;
 STICKLINE(VAR327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
 DRAWTEXT(VAR327>90,LOW*0.95,'追涨'),COLORYELLOW;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭