程序化指标公式
问答中心

同花顺农民炒股主图指标公式

同花顺公式 2019-05-31阅读量:793

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击  安装指南  步骤操作


MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120);
MA250:MA(CLOSE,250);
VARR1:=(CLOSE+HIGH+LOW)/3;
VARR2:=EMA(VARR1,10);
VARR3:=REF(VARR2,1);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);//程序化指标 官方网址:www.honghaie.com
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW*0.95,'←播种'),colorred,LINETHICK2;
DRAWICON(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW*0.95,17);
VAR1:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
DRAWTEXT(VAR1>90,LOW*0.92,'←追肥'),COLORFF00FF;
DRAWICON(VAR1>90,LOW*0.92,25);
VAR2:=(POW(MA(CLOSE,5),2)+MA(CLOSE,5));
VAR3:=(POW(MA(LOW,5),2)+MA(LOW,5));
VAR4:=(POW(MA(HIGH,5),2)+MA(HIGH,5));
VAR5:=(((((VAR2-LLV(VAR3,64))/(HHV(VAR4,64)-LLV(VAR3,64)))*150)+65)-10);
VAR6:=((SMA(VAR5,3,1)*1.5)-100);
VAR7:=SMA(VAR6,3,1);
VAR8:=((3*VAR6)-(2*VAR7));
VAR9:=(((HIGH+LOW)+(CLOSE*2))/4);
VAR10:=EMA(VAR9,13);
VAR11:=STD(VAR9,13);
VAR12:=(((VAR9-VAR10)*100)/VAR11);
VAR13:=EMA(VAR12,5);
VAR15:=((EMA(VAR13,13)+200)-100);
VAR16:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
DRAWTEXT(FILTER(VAR16<-9 AND VAR16>REF(VAR16,1),18),L*0.9,'←抢播♂'),colorred,LINETHICK2;
DRAWICON(FILTER(VAR16<-9 AND VAR16>REF(VAR16,1),18),L*0.9,1);
VAR17:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR18:=VAR8<REF(VAR17,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
大资金:=(VAR18 AND COUNT(VAR18,30)=1);
DRAWTEXT(大资金,LOW*0.85,'▲大资金');
AA:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B11:=L-A0;
STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B11,B11-1.5*A0,2,0),COLORF00FF0;
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B11-1*A0,'季节变化'),colorligreen;
VAR22:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR23:=(HIGH+LOW+CLOSE)/3;
VAR24:=(VAR23-MA(VAR23,14))/(0.015*AVEDEV(VAR23,14));
VAR25:=(VAR23-MA(VAR23,70))/(0.015*AVEDEV(VAR23,70));
VAR26:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR27:=100-ABS(VAR26);
VAR28:=IF(VAR27<90,VAR27,100);
VAR29:=IF(VAR22>0,VAR22,0);
VAR30:=IF(VAR25>=200 AND VAR24>=150,15,IF(VAR25<=-200 AND VAR24<=-150,-15,VAR15))+60;
VAR31:=VAR29>48 AND VAR30>60 AND VAR28<100;
DRAWTEXT(VAR31 AND COUNT(VAR31,30)=1,HIGH*1.02,'大笔出货'),LINETHICK1,COLORFFCC66;
XXS:=MA(HIGH,5)*(1+5/100);
DRAWTEXT(CROSS(XXS,C),H,'←收割'),colorgreen,LINETHICK1;
DRAWICON(CROSS(XXS,C),H*1.05,9);
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
鼠:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;
DRAWTEXT(鼠,(LOW* 0.99),'←鼠'),COLOR40CCFF;
DRAWICON(鼠,(LOW* 0.99),23);//程序化指标 官方网址:www.honghaie.com
VAR013:=IF(MA(CLOSE,13)>REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL);
跟进:=IF(CROSS(K,D) OR CROSS(REF(K,1),REF(D,1)) OR CROSS(REF(K,2),REF(D,2)),10,0),coloryellow;
RSV2:=(CLOSE - LLV(LOW,18))/(HHV(HIGH,18) - LLV(LOW,18))*100;
K2:=EMA(RSV2,3);
D2:=EMA(K2,3);
J2:=(3*K2-2*D2);
KDJ2:=REF(COUNT(J2<REF(J2,1),5)>=3,1) AND REF(J2,1)<20;
KDJ3:=J2>REF(J2,1);
反转:=IF(FILTER(KDJ2 AND KDJ3,3),50,0),colorred;
买:=IF(CROSS(J,2),35,0);
VAR222:=REF(LOW,1);
VAR332:=SMA(ABS(LOW-VAR222),3,1)/SMA(MAX(LOW-VAR222,0),3,1)*100;
VAR442:=EMA(IF(CLOSE*1.3,VAR332*10,VAR332/10),3);
VAR552:=LLV(LOW,13);
VAR662:=HHV(VAR442,13);
VAR772:=IF(MA(CLOSE,34),1,0);
VAR888:=EMA(IF(LOW<=VAR552,(VAR442+VAR662*2)/2,0),3)/618*VAR772;
VAR999:=IF(VAR888>100,100,VAR888);
吸筹:=VAR999,LINETHICK1,COLORCD7F32 ;
HH:=CONST(HHV(C,120))*1;
LL:=CONST(LLV(C,120))*1;
HL:=CONST(IF(CONST((HH+LL)/2)<CONST(C),LL-(HH-LL)*0.4,HH+(HH-LL)*0.4));
HH1:=IF(CONST((HH+LL)/2)>CONST(C),HH,HL);

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭